PHP.EE FOORUM   
Nimi:   Pass:   Mäleta mind! 
   Teemad | php.ee esilehele | registreeri | Märgi kõik teemad loetuks | #php.ee Skype vestlus | RSS
UUS TEEMA  OTSI  Lehekülgi: 1
Jquery võlu ja valu
Postitaja: joker 2010-04-12 21:25:23
Olen kasutanud oma softis erinevaid JQuery pluginaid, ning jõudnud arusaamisele, et asi on ikka päris jama.

Üks plugin töötab JQuery üle versiooniga, teine teise versiooniga.
Proovisin kasutasin Jquery kõige uuemat versiooni, kuid siis hakkasid anomaaliad pluginatega pihta.

Kas JQuery puhul ongi selline asi normaalne?!
RE: Jquery võlu ja valu
Postitaja: puuder 2010-04-12 21:43:56
ei ei ei ole normaalne , seee on täiesti ebanormaalne , ära rohkem seda kunagi tee , ära puuderda rohkem
RE: Jquery võlu ja valu
Postitaja: Waher 2010-04-13 00:08:03
jQuery on täiesti vapustav asi, tundub et Sa pole lihtsalt seda endale selgeks õppinud. Paljud incompatible jQuery nii-öelda pluginad on taastehtavad 10 minuti koodikirjutamisega või versioonierinevused kohandatavad käsitsi. Kõige enam on aga asi lihtsalt selles, et see on valesti implementeeritud.

Enamus projektidel pole mul kunagi pluginaid vaja, ainsad erandid tulevad budget projektidel, kus galerii on suhtkoht ainus, mis tuleb läbi plugina.

Soovitan raamatut 'jQuery in Action', ning jah, see on normaalne - nii jQuery puhul kui ka tarkvara-arenduses üldiselt - et versiooniuuendusega võib juhtuda, et vanad pluginad ei tööta.

Leheküljed: 1

©2002-2013 Martin Rebane & PHP.ee kaasautorid
  0.078626871109